GPS accuracy way off

GPS accuracy way off

Postby daveyrand » Wed Apr 08, 2015 8:20 am

Since the last update I've had a couple of problems with my Leikr returning some really odd GPS results. The first time it happened (Thursday evening) I discarded the results, but the problem reoccurred last night too.

The issue occurs when I'm cycling out of central London. I mention that because the Leikr sometimes struggles to get a GPS signal, presumably due to tall buildings and the like. I usually turn the watch on for about 15 minutes before the window, run a Wifi sync and leave it by the window. Before leaving on both occasions of this problem the Leikr reported it had a good fix (4 or 5 satellites).

I've attached some screenshots of the workout map from Endomondo. Fig1 shows my usual route, which I was doing on this occasion. Fig2 is what the GPS tracked. As you can see, it's miles off and nothing like what I actually did.

During the ride the stats on the Leikr were very odd. The distance would not move at all for some time, but would then jump up by 1 or 2 KM. It would say I had 4 or 5 satellites while I was stationery, but despite having auto-pause on the time would continue to count up. Then when I moved again the satellite count would very quickly switch between 0, and about 4/5. I also noticed on several occasions that the total distance stat jumped by 2 to 3 KM, but would then change back to what it was. Unfortunately I do not have a map view on the sport profile I was using, so cannot comment on what that may have been doing.

Has anyone encountered any similar behaviour? Is there anything I can do to stop it happening in future?
Attachments
fig1.png
My usual route, correctly tracked from a previous workout
fig1.png (184.5 KiB) Viewed 4399 times
fig2.png
The result when I cycled the same route
fig2.png (186.66 KiB) Viewed 4399 times
daveyrand
 
Posts: 6
Joined: Wed Jun 18, 2014 1:49 pm

Return to Bug reporting

Who is online

Users browsing this forum: No registered users and 2 guests