Windows doesn't find Leikr as a device

Windows doesn't find Leikr as a device

Postby erikhs » Tue Jul 22, 2014 1:05 pm

After having given up on the Leikr watch (haven't used it for a very long time) I decided to give it a last chance.
I have changed our WIFI so first I needed to update the configuration file on the watch but when I plug it in to the USB port on my PC Windows doesn't not recognize the "Mass storage unit" which means that I can't transfer the config file.
I have tried to connect the watch to 2 different PCs (one running Win7 and one running Win8) with the same negative result.
I have also tried to look at the Device Manager in Windows and uninstalled/installed the device but it fails on the Win7 computer and on the Win8 computer it doesn't even show as a device.
I have tried everything else - restarting the PC's and searched for hardware changes in the Device Manager and my conclusion is therefore that there is a hardware defect on the watch.
Selecting "Factory reset" on the watch menu doesn't have any effect either. Please let me know if there is another reset option and/or where to return the watch to.
Posts: 1
Joined: Tue Jul 02, 2013 9:50 am

Re: Windows doesn't find Leikr as a device

Postby admin » Wed Jul 23, 2014 1:25 pm

dear Erikhs,
we need to get a bit more info to start troubleshooting. Please write a mail to and we will find a solution.
Site Admin
Posts: 641
Joined: Wed May 29, 2013 4:42 pm

Return to Bug reporting

Who is online

Users browsing this forum: No registered users and 1 guest